# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?/$1\n$2/gm;t' <<< "Shapes: circle, rectangle, triangle
Junk line: this part, here, should work, but: make sure, that last colon, isn't caught
One: two, three
Yellow: Blue, Green"