$re = '/(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?/m';
$str = 'Shapes: circle, rectangle, triangle
Junk line: this part, here, should work, but: make sure, that last colon, isn\'t caught
One: two, three
Yellow: Blue, Green';
$subst = "$1\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;