# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?"
test_str = ("Shapes: circle, rectangle, triangle\n"
"Junk line: this part, here, should work, but: make sure, that last colon, isn't caught\n"
"One: two, three\n"
"Yellow: Blue, Green")
subst = "$1\\n$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.