use strict;
my $str = 'Shapes: circle, rectangle, triangle
Junk line: this part, here, should work, but: make sure, that last colon, isn\'t caught
One: two, three
Yellow: Blue, Green';
my $regex = qr/(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?/mp;
my $subst = '$1\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";