using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?";
string substitution = @"$1\n$2";
string input = @"Shapes: circle, rectangle, triangle
Junk line: this part, here, should work, but: make sure, that last colon, isn't caught
One: two, three
Yellow: Blue, Green";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}