const regex = /(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^:]+:|\\G(?!^))\\h*([^,\\r\\n]+),?', 'gm')
const str = `Shapes: circle, rectangle, triangle
Junk line: this part, here, should work, but: make sure, that last colon, isn't caught
One: two, three
Yellow: Blue, Green`;
const subst = `$1\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);