#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[^:]+:|\G(?!^))\h*([^,\r\n]+),?"
Local $sString = "Shapes: circle, rectangle, triangle" & @CRLF & _
"Junk line: this part, here, should work, but: make sure, that last colon, isn't caught" & @CRLF & _
"One: two, three" & @CRLF & _
"Yellow: Blue, Green"
Local $sSubst = "$1\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)