import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^:]+:|\\G(?!^))\\h*([^,\\r\\n]+),?";
final String string = "Shapes: circle, rectangle, triangle\n"
+ "Junk line: this part, here, should work, but: make sure, that last colon, isn't caught\n"
+ "One: two, three\n"
+ "Yellow: Blue, Green";
final String subst = "$1\\n$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}