package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)`)
var str = `<table style="background-image: url('http://www1.xup.to/exec/ximg.php?fid=18248939'); background-size: 100% auto; height: 1075px;" width="772">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}