// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)"#).unwrap();
let string = "<table style=\"background-image: url('http://www1.xup.to/exec/ximg.php?fid=18248939'); background-size: 100% auto; height: 1075px;\" width=\"772\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}