import Foundation
let pattern = #"background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<table style="background-image: url('http://www1.xup.to/exec/ximg.php?fid=18248939'); background-size: 100% auto; height: 1075px;" width="772">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}