re = /background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)/
str = '<table style="background-image: url(\'http://www1.xup.to/exec/ximg.php?fid=18248939\'); background-size: 100% auto; height: 1075px;" width="772">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end