use strict;
my $str = '<table style="background-image: url(\'http://www1.xup.to/exec/ximg.php?fid=18248939\'); background-size: 100% auto; height: 1075px;" width="772">';
my $regex = qr/background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}