const regex = /background\-image:(?: {1,}|)url(?: {1,}|)\(['|"](.*)['|"]\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('background\\-image:(?: {1,}|)url(?: {1,}|)\\([\'|"](.*)[\'|"]\\)', '')
const str = `<table style="background-image: url('http://www1.xup.to/exec/ximg.php?fid=18248939'); background-size: 100% auto; height: 1075px;" width="772">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}