using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"الدولار(.\d+)";
string input = @"some other text
يمة بيع الدولار 550
قيمة بيع اليورو 600
قيمة شراء الدولار 700
قيمة122
ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}