use strict;
my $str = 'some other text
يمة بيع الدولار 550
قيمة بيع اليورو 600
قيمة شراء الدولار 700
قيمة122
ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:';
my $regex = qr/الدولار(.\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}