package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)الدولار(.\d+)`)
var str = `some other text
يمة بيع الدولار 550
قيمة بيع اليورو 600
قيمة شراء الدولار 700
قيمة122
ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}