import re
regex = re.compile(r"الدولار(.\d+)", flags=re.MULTILINE)
test_str = ("some other text\n"
"يمة بيع الدولار 550\n"
"قيمة بيع اليورو 600\n"
"قيمة شراء الدولار 700\n"
"قيمة122\n"
"ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")