import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "الدولار(.\\d+)";
final String string = "some other text\n"
+ "يمة بيع الدولار 550\n"
+ "قيمة بيع اليورو 600\n"
+ "قيمة شراء الدولار 700\n"
+ "قيمة122\n"
+ "ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}