re = /الدولار(.\d+)/m
str = 'some other text
يمة بيع الدولار 550
قيمة بيع اليورو 600
قيمة شراء الدولار 700
قيمة122
ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end