// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)الدولار(.\d+)").unwrap();
let string = "some other text
يمة بيع الدولار 550
قيمة بيع اليورو 600
قيمة شراء الدولار 700
قيمة122
ا هي قيم العملة يوم 4/2/2022 الساعة 9:00:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}