# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{3})(\d)/\1.\2/gm;t' <<< "0781
00840
8660
7100
25011"