import Foundation
let pattern = #"^(\d{3})(\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0781
00840
8660
7100
25011
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)