const regex = /^(\d{3})(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{3})(\\d)', 'gm')
const str = `0781
00840
8660
7100
25011`;
const subst = `\1.\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);