package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{3})(\d)`)
var str = `0781
00840
8660
7100
25011`
var substitution = "\1.\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}