use strict;
my $str = '0781
00840
8660
7100
25011';
my $regex = qr/^(\d{3})(\d)/mp;
my $subst = '\\1.\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";