re = /^(\d{3})(\d)/m
str = '0781
00840
8660
7100
25011'
subst = '\\1.\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result