#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{3})(\d)"
Local $sString = "0781" & @CRLF & _
"00840" & @CRLF & _
"8660" & @CRLF & _
"7100" & @CRLF & _
"25011"
Local $sSubst = "\1.\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)