# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\\/section>\s*/<!-- $1 -->\n$2/gm;t' <<< "<section className={class-a}>
Un-touched stuff here
</section>
<hr />
<section className={class-b}>
Un-touched stuff here
</section>
<hr />"