use strict;
my $str = '<section className={class-a}>
Un-touched stuff here
</section>
<hr />
<section className={class-b}>
Un-touched stuff here
</section>
<hr />';
my $regex = qr/<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*/mp;
my $subst = '<!-- $1 -->\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";