#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*"
Local $sString = "<section className={class-a}>" & @CRLF & _
"" & @CRLF & _
"Un-touched stuff here" & @CRLF & _
"" & @CRLF & _
"</section>" & @CRLF & _
"" & @CRLF & _
"<hr />" & @CRLF & _
"" & @CRLF & _
"<section className={class-b}>" & @CRLF & _
"" & @CRLF & _
"Un-touched stuff here" & @CRLF & _
"" & @CRLF & _
"</section>" & @CRLF & _
"" & @CRLF & _
"<hr />"
Local $sSubst = "<!-- $1 -->\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)