$re = '/<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*/m';
$str = '<section className={class-a}>
Un-touched stuff here
</section>
<hr />
<section className={class-b}>
Un-touched stuff here
</section>
<hr />';
$subst = "<!-- $1 -->\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;