const regex = /<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<section\\s+className\\=\\{([^>]*)\\}>([\\s\\S]*?)<\\\/section>\\s*', 'gm')
const str = `<section className={class-a}>
Un-touched stuff here
</section>
<hr />
<section className={class-b}>
Un-touched stuff here
</section>
<hr />`;
const subst = `<!-- $1 -->\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);