package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*`)
var str = `<section className={class-a}>
Un-touched stuff here
</section>
<hr />
<section className={class-b}>
Un-touched stuff here
</section>
<hr />`
var substitution = "<!-- $1 -->\n$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}