import re
regex = re.compile(r"<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*", flags=re.MULTILINE)
test_str = ("<section className={class-a}>\n\n"
"Un-touched stuff here\n\n"
"</section>\n\n"
"<hr />\n\n"
"<section className={class-b}>\n\n"
"Un-touched stuff here\n\n"
"</section>\n\n"
"<hr />")
subst = "<!-- $1 -->\\n$2"
result = regex.sub(subst, test_str)
if result:
print(result)