import Foundation
let pattern = #"<section\s+className\=\{([^>]*)\}>([\s\S]*?)<\/section>\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<section className={class-a}>
Un-touched stuff here
</section>
<hr />
<section className={class-b}>
Un-touched stuff here
</section>
<hr />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<!-- $1 -->\n$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)