#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*website.com($|\/$|\?.*)"
Local $sString = "https://website.com/" & @CRLF & _
"https://website.com?utm_source=test&utm_medium=test&utm_campaign=test" & @CRLF & _
"website.com" & @CRLF & _
"http://website.com" & @CRLF & _
"https://website.com/about/" & @CRLF & _
"https://website.com/product123" & @CRLF & _
"https://website.com/services" & @CRLF & _
"https://website.com/blog" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")