import re
regex = re.compile(r"^.*website.com($|\/$|\?.*)", flags=re.MULTILINE)
test_str = ("https://website.com/\n"
"https://website.com?utm_source=test&utm_medium=test&utm_campaign=test\n"
"website.com\n"
"http://website.com\n"
"https://website.com/about/\n"
"https://website.com/product123\n"
"https://website.com/services\n"
"https://website.com/blog\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")