// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*website.com($|\/$|\?.*)").unwrap();
let string = "https://website.com/
https://website.com?utm_source=test&utm_medium=test&utm_campaign=test
website.com
http://website.com
https://website.com/about/
https://website.com/product123
https://website.com/services
https://website.com/blog
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}