import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*website.com($|\\/$|\\?.*)";
final String string = "https://website.com/\n"
+ "https://website.com?utm_source=test&utm_medium=test&utm_campaign=test\n"
+ "website.com\n"
+ "http://website.com\n"
+ "https://website.com/about/\n"
+ "https://website.com/product123\n"
+ "https://website.com/services\n"
+ "https://website.com/blog\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}