const regex = /^.*website.com($|\/$|\?.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*website.com($|\\\/$|\\?.*)', 'gm')
const str = `https://website.com/
https://website.com?utm_source=test&utm_medium=test&utm_campaign=test
website.com
http://website.com
https://website.com/about/
https://website.com/product123
https://website.com/services
https://website.com/blog
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}