use strict;
my $str = 'https://website.com/
https://website.com?utm_source=test&utm_medium=test&utm_campaign=test
website.com
http://website.com
https://website.com/about/
https://website.com/product123
https://website.com/services
https://website.com/blog
';
my $regex = qr/^.*website.com($|\/$|\?.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}