package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*website.com($|\/$|\?.*)`)
var str = `https://website.com/
https://website.com?utm_source=test&utm_medium=test&utm_campaign=test
website.com
http://website.com
https://website.com/about/
https://website.com/product123
https://website.com/services
https://website.com/blog
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}