$re = '/^.*website.com($|\/$|\?.*)/m';
$str = 'https://website.com/
https://website.com?utm_source=test&utm_medium=test&utm_campaign=test
website.com
http://website.com
https://website.com/about/
https://website.com/product123
https://website.com/services
https://website.com/blog
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);