#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-+\d+$"
Local $sString = "-500--550" & @CRLF & _
"-600--650" & @CRLF & _
"-700--750" & @CRLF & _
"-8000--8500" & @CRLF & _
"-9000--9500" & @CRLF & _
"-100-200" & @CRLF & _
"200-400"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)