import re
regex = re.compile(r"-+\d+$", flags=re.MULTILINE)
test_str = ("-500--550\n"
"-600--650\n"
"-700--750\n"
"-8000--8500\n"
"-9000--9500\n"
"-100-200\n"
"200-400")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)