use strict;
my $str = '-500--550
-600--650
-700--750
-8000--8500
-9000--9500
-100-200
200-400';
my $regex = qr/-+\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";