package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-+\d+$`)
var str = `-500--550
-600--650
-700--750
-8000--8500
-9000--9500
-100-200
200-400`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}