$re = '/-+\d+$/m';
$str = '-500--550
-600--650
-700--750
-8000--8500
-9000--9500
-100-200
200-400';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;