using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-+\d+$";
string substitution = @"";
string input = @"-500--550
-600--650
-700--750
-8000--8500
-9000--9500
-100-200
200-400";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}